flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nsengupta <sengupta.nirma...@gmail.com>
Subject Re: Compiler error while using 'CsvTableSource'
Date Fri, 03 Feb 2017 03:05:43 GMT
Hello Till,

Many thanks for a quick reply. 

I have tried to follow your suggestion, with no luck:
<http://apache-flink-user-mailing-list-archive.2336050.n4.nabble.com/file/n11421/Selection_251.png>


Just to give it a shot, I have tried this too (following Flink
Documentation):

<http://apache-flink-user-mailing-list-archive.2336050.n4.nabble.com/file/n11421/Selection_252.png>



I took, a cursory look at the source code and stumbled upon this file:
./flink-libraries/flink-table/src/test/scala/org/apache/flink/table/utils/*CommonTestData.scala*

Here, I see that you are using *BasicTypeInfo* while creating a
*CsvTableSource* and I have tried that too:

<http://apache-flink-user-mailing-list-archive.2336050.n4.nabble.com/file/n11421/Selection_253.png>


Because I ordered maven to skipTests, while building Flink binaries, I don't
know if this particular testcase passed or not. If it did, then I think we
can conclude that it is a case of Scala's failure to resolve type, perhaps
due to an implicit. It it didn't, then we perhaps have an easier problem to
solve.

Do you think I should run all the tests in my environment? It may take time,
but I can do that if it helps us.

-- Nirmalya







--
View this message in context: http://apache-flink-user-mailing-list-archive.2336050.n4.nabble.com/Compiler-error-while-using-CsvTableSource-tp11412p11421.html
Sent from the Apache Flink User Mailing List archive. mailing list archive at Nabble.com.

Mime
View raw message