flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Debugging Python-Api fails with NoClassDefFoundError
Date Wed, 04 Jan 2017 20:52:47 GMT
This class is in flink-core jar.

Have you verified that the jar is on classpath ?

Cheers

On Wed, Jan 4, 2017 at 12:16 PM, Mathias Peters <mathias.peters@gmx.org>
wrote:

> Hi,
>
> I just wanted to debug a custom python script using your python dataset
> api. Running the PythonPlanBinder in Intellij IDEA gives me the
> subjected error. I took a fresh clone, built it with mvn clean install
> -DskipTest, and imported everything in idea. Using an older version this
> worked fine, so assume no(t the usual noob) errors on my side
>
> Submitting a python script via console works.
>
> The full stack trace looks like this:
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/flink/api/java/typeutils/TupleTypeInfoBase
>     at java.lang.Class.forName0(Native Method)
>     at java.lang.Class.forName(Class.java:264)
>     at com.intellij.rt.execution.application.AppMain.main(AppMain.java:122)
> Caused by: java.lang.ClassNotFoundException:
> org.apache.flink.api.java.typeutils.TupleTypeInfoBase
>     at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
>     at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
>     at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
>     at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
>     ... 3 more
>
>
> Thanks for the help.
>
> best
>
> Mathias
>
>
>

Mime
View raw message