flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maximilian Michels <...@apache.org>
Subject [DISCUSS] Storm 1.x.x support in the compatibility layer
Date Fri, 02 Sep 2016 13:25:20 GMT
This should be of concern mostly to the users of the Storm compatibility layer:

We just received a pull request [1] for updating the Storm
compatibility layer to support Storm versions >= 1.0.0. This is a
major change because all Storm imports have changed their namespace
due to package renaming.

If we merged this pull request we would have two modules, one for
Storm < 1.0.0 and one for Storm >= 1.0.0. This would require a lot of
duplicate work for the Flink community.

Thus, I would suggest to remove the Storm compatibility for < 1.0.0
and focus on supporting 1.x.x versions of Storm.

What do you think? In particular, how do Storm users think about this?

Cheers,
Max

[1] https://github.com/apache/flink/pull/2452

Mime
View raw message