flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shannon Carey <sca...@expedia.com>
Subject Re: Flink WebUI on YARN behind firewall
Date Mon, 29 Aug 2016 15:14:37 GMT
I've noticed this too. The UI incorrectly tries to load its resources (CSS, JS) from root.
Try adding a trailing slash to the URL.

-Shannon

From: Trevor Grant <trevor.d.grant@gmail.com<mailto:trevor.d.grant@gmail.com>>
Date: Friday, August 26, 2016 at 12:52 PM
To: <user@flink.apache.org<mailto:user@flink.apache.org>>
Subject: Flink WebUI on YARN behind firewall

I decided it made the most sense to open up a new thread.

I am running Flink on a cluster behind a firewall.  Things seem to be working fine, but when
I access the YARN web-ui and click on the flink application-ui, i get the jobmanager ui, but
it is broken.

It is a broken link to a flink image and
[Apache Flink Dashboard]Apache Flink Dashboard

  *    Overview
  *    Running Jobs
  *    Completed Jobs
  *    Task Managers
  *    Job Manager
  *    Submit new Job

but none of the links work, no images no pretty formatting.  does anyone have a quick idea
why this would be?  I found http://mail-archives.apache.org/mod_mbox/flink-user/201511.mbox/%3CCAGr9p8B_aKhbjLqVQQUZeO_eSz6P=eWKP+Kg1sQ65SB0npsX2Q@mail.gmail.com%3E

but that seems to be more related to running jobs than accessing the UI

any help would be appreciated

tg


Trevor Grant
Data Scientist
https://github.com/rawkintrevo
http://stackexchange.com/users/3002022/rawkintrevo
http://trevorgrant.org

"Fortunate is he, who is able to know the causes of things."  -Virgil

Mime
View raw message