flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bajaj, Abhinav" <abhinav.ba...@here.com>
Subject Re: Submitting job via Flink web interface giving Null pointer exception
Date Thu, 02 Jun 2016 22:28:06 GMT
Hi Ritesh,

I tried to run a local flink using the same script and submitted a job successfully via Web
interface and command line both.
I suggest to try one of the flink examples.
Streaming Job - https://ci.apache.org/projects/flink/flink-docs-release-1.0/quickstart/run_example_quickstart.html
Batch Job - https://ci.apache.org/projects/flink/flink-docs-release-1.0/apis/batch/examples.html

May be this help in identifying where the problem lies, with the flink setup or the job.

Best,
Abhi


From: Ritesh Kumar Singh <riteshoneinamillion@gmail.com<mailto:riteshoneinamillion@gmail.com>>
Reply-To: "user@flink.apache.org<mailto:user@flink.apache.org>" <user@flink.apache.org<mailto:user@flink.apache.org>>
Date: Thursday, June 2, 2016 at 3:28 AM
To: "user@flink.apache.org<mailto:user@flink.apache.org>" <user@flink.apache.org<mailto:user@flink.apache.org>>
Subject: Re: Submitting job via Flink web interface giving Null pointer exception

on command line I'm executing: $ flink run project.jar

This is on a Flink standalone mode of deployment using the start-local.sh script. The web
interface is running into Null pointer exception on an internal codebase. Weird thing is that
it does not happen when submitting the job via commandline


On Thu, Jun 2, 2016 at 2:08 AM, Bajaj, Abhinav <abhinav.bajaj@here.com<mailto:abhinav.bajaj@here.com>>
wrote:
Hi Ritesh,

We are using Flink 1.0.0 and don’t have issues with using the command line or the web interface.

Can you please share some details on the command you are using and probably a screen shot
of the web interface with the values used for submission.
You are running Flink standalone or over Yarn ?

Best,
Abhi

From: Ritesh Kumar Singh <riteshoneinamillion@gmail.com<mailto:riteshoneinamillion@gmail.com>>
Reply-To: "user@flink.apache.org<mailto:user@flink.apache.org>" <user@flink.apache.org<mailto:user@flink.apache.org>>
Date: Wednesday, June 1, 2016 at 11:11 AM
To: "user@flink.apache.org<mailto:user@flink.apache.org>" <user@flink.apache.org<mailto:user@flink.apache.org>>
Subject: Submitting job via Flink web interface giving Null pointer exception

Hi,

I'm not sure if anyone has faced a similar issue with Flink_v1.0.0 that it's behaving differently
when I submit a job via command line and when I do the same using Flink web interface.

The web interface is giving me Null pointer exceptions when the same is working via the command
line and from an eclipse environment. Is it some sort of bug that is already known or are
there some adjustments that need to be done before uploading the jar?


Thanks,
--
Ritesh Kumar Singh
https://riteshtoday.wordpress.com/



--
Ritesh Kumar Singh
https://riteshtoday.wordpress.com/
Mime
View raw message