flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From subash basnet <yasub...@gmail.com>
Subject Re: Streaming error, StockPrices example
Date Wed, 25 May 2016 15:32:05 GMT
Hello Ufuk,

Yeah I had tried running the examples via eclipse, yeah it should have
setup all dependencies but no it doesn't. It shows error with regard to
*SourceContext* not available as explained via image in earlier thread.
So I had to add this new depedency in maven to get rid of *SourceContext* not
available error as below:

<dependency>
<groupId>org.apache.flink</groupId>
<artifactId>flink-streaming-core</artifactId>
<version>0.9.0</version>
</dependency>

But after adding this dependency the previous *SourceContext* error get's
removed but now another new @override error occurs inside the inner class
StockSource, the image of error is attached earlier.


Best Regards,
Subash Basnet

On Fri, May 20, 2016 at 12:16 PM, Ufuk Celebi <uce@apache.org> wrote:

> [image: Boxbe] <https://www.boxbe.com/overview> This message is eligible
> for Automatic Cleanup! (uce@apache.org) Add cleanup rule
> <https://www.boxbe.com/popup?url=https%3A%2F%2Fwww.boxbe.com%2Fcleanup%3Ftoken%3DYVGiiSzHoQEJ1%252FUzgVIdzIT86D5a2ZvFeL1dT9Aa3FUjPTk5PVsP8Z8DMoc9J3yfq57J5xQ74zePeUPvdzLLBSjqjw%252F91ioXWhLzNL3HJ7sHi%252B3Bb0cWCNjAJ8qWw2CJTRzrYwfBATI%253D%26key%3DSmJxha2XmnfB2jEhiVYNvM0lrYWtsUhLKa4Fx%252BHGlfQ%253D&tc_serial=25471796499&tc_rand=751862306&utm_source=stf&utm_medium=email&utm_campaign=ANNO_CLEANUP_ADD&utm_content=001>
> | More info
> <http://blog.boxbe.com/general/boxbe-automatic-cleanup?tc_serial=25471796499&tc_rand=751862306&utm_source=stf&utm_medium=email&utm_campaign=ANNO_CLEANUP_ADD&utm_content=001>
>
> Hey Subash! The example is not part of the Flink distribution (any more).
> Probably you are running into a version mismatch. The examples packages you
> are referring to actually sets up all dependencies. How are you trying to
> run this?
>
> On Sat, May 14, 2016 at 3:03 PM, subash basnet <yasubash@gmail.com> wrote:
>
>> Hello all,
>>
>> The StockPrices.java example of the given link,
>> StreamingExamples
>> <https://github.com/mbalassi/flink/tree/stockprices/flink-staging/flink-streaming/flink-streaming-examples>
>> shows error due to lack of* SourceContext* class in the provided
>> flink-streaming-core jar as given in maven.
>>
>> ​
>> So I added another dependency as below in maven:
>> <dependency>
>> <groupId>org.apache.flink</groupId>
>> <artifactId>flink-streaming-core</artifactId>
>> <version>0.9.0</version>
>> </dependency>
>>
>> Now the SourceContext is found, but shows @override error in the inner
>> class StockSource.
>>
>>
>>
>> Best Regards,
>> Subash Basnet
>> ​
>>
>
>
>

Mime
View raw message