flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Metzger <rmetz...@apache.org>
Subject Flink 1.0.0 Release Candidate 0: Please help testing
Date Mon, 15 Feb 2016 19:47:18 GMT
Hi,

I've now created a "preview RC" for the upcoming 1.0.0 release.
There are still some blocking issues and important pull requests to be
merged but nevertheless I would like to start testing Flink for the release.

In past major releases, we needed to create many release candidates, often
for fixing just some small issues. I would like to speed up the release
process by collecting as many issues as possible now with the RC0. Once
these issues are resolved, we can start voting with the RC1.

We have a Wiki page
https://cwiki.apache.org/confluence/display/FLINK/Releasing containing some
common release verification tasks.

Also, production users are encouraged to participate in the release
verification process.

Here are the preview binaries located:
http://people.apache.org/~rmetzger/flink-1.0.0-rc0/
This is the staging repository:
https://repository.apache.org/content/repositories/orgapacheflink-1062


To use the release candidate in an existing pom project, set the Flink
version to 1.0.0 and the repository URL to
https://repository.apache.org/content/repositories/orgapacheflink-1062.
The pom should look like this:

<properties>
   <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
   <flink.version>1.0.0</flink.version>
</properties>

<repositories>
   <repository>
      <id>flink.release-staging</id>
      <name>Apache Development Snapshot Repository</name>
      <url>https://repository.apache.org/content/repositories/orgapacheflink-1062</url>
      <releases><enabled>true</enabled></releases>
      <snapshots><enabled>false</enabled></snapshots>
   </repository>
</repositories>




Let me start a list of issues we need to resolve:
- Ensure the release is build with maven < 3.3 (the RC0 has been build with
Maven 3.3, so the Guava shading is not done properly.)
- flink-cep depends on Scala, but the artifact doesn't have a scala version
suffix.
- the flink-quickstart-java is referring to scala 2.11 by default.

Please add more issues to the list ....

Mime
View raw message