flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephan Ewen <se...@apache.org>
Subject Re: Cannot start FlinkMiniCluster.WebServer using different port in FlinkMiniCluster
Date Wed, 20 Jan 2016 18:20:18 GMT
I think this null pointer comes when the log files are not found (bug in
0.10).

You can double check by either trying 1.0-SNAPSHOT or putting for test an
absolute path of a file that exists for the log file.

Greetings,
Stephan

On Wed, Jan 20, 2016 at 6:33 PM, Till Rohrmann <trohrmann@apache.org> wrote:

> I guess it’s easiest to simply enable logging and see what the problem is.
> If you run it from the IDE then you can also set a breakpoint in
> WebMonitorUtils.startWebRuntimeMonitor and see what the exception is.
>
> Cheers,
> Till
> ​
>
> On Wed, Jan 20, 2016 at 6:04 PM, HungChang <unicorn.banachi@gmail.com>
> wrote:
>
>> Yea I'm wondering why the web server cannot be instantiated because
>> changing
>> the port 8081 to 9999 works well in the following demo sample of Flink.
>>
>> https://github.com/dataArtisans/flink-streaming-demo/blob/master/src/main/scala/com/dataartisans/flink_demo/utils/DemoStreamEnvironment.scala
>>
>> so is the code of Flink syntax correct and I should try to find other
>> issues?
>>
>> Best,
>>
>> Sendoh
>>
>>
>>
>> --
>> View this message in context:
>> http://apache-flink-user-mailing-list-archive.2336050.n4.nabble.com/Cannot-start-FlinkMiniCluster-WebServer-using-different-port-in-FlinkMiniCluster-tp4414p4420.html
>> Sent from the Apache Flink User Mailing List archive. mailing list
>> archive at Nabble.com.
>>
>
>

Mime
View raw message