flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ritesh Kumar Singh <riteshoneinamill...@gmail.com>
Subject Compile fails with scala 2.11.4
Date Mon, 18 Jan 2016 10:24:22 GMT
[ERROR]
/home/flink/flink-runtime/src/test/scala/org/apache/flink/runtime/jobmanager/JobManagerITCase.scala:703:
*error: can't expand macros compiled by previous versions of Scala*
[ERROR]               assert(cachedGraph2.isArchived)
[ERROR]                                   ^
[ERROR] one error found
[INFO]
------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] flink .............................................. SUCCESS [
24.820 s]
[INFO] flink-annotations .................................. SUCCESS [
 2.755 s]
[INFO] flink-shaded-hadoop ................................ SUCCESS [
 0.208 s]
[INFO] flink-shaded-hadoop2 ............................... SUCCESS [
15.627 s]
[INFO] flink-shaded-include-yarn-tests .................... SUCCESS [
17.076 s]
[INFO] flink-shaded-curator ............................... SUCCESS [
 0.200 s]
[INFO] flink-shaded-curator-recipes ....................... SUCCESS [
 2.751 s]
[INFO] flink-shaded-curator-test .......................... SUCCESS [
 0.355 s]
[INFO] flink-core ......................................... SUCCESS [
33.052 s]
[INFO] flink-java ......................................... SUCCESS [
10.224 s]
[INFO] flink-runtime ...................................... FAILURE [01:23
min]
[INFO] flink-optimizer .................................... SKIPPED


Any workaround for scala_2.11.4 or do I have to switch back to scala_2.10.4
?

Thanks,
*Ritesh Kumar Singh,*
*https://riteshtoday.wordpress.com/* <https://riteshtoday.wordpress.com/>

Mime
View raw message