flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Metzger <rmetz...@apache.org>
Subject Re: Building Flink with hadoop 2.6
Date Wed, 14 Oct 2015 15:00:27 GMT
Ah, I know what's causing this issue.
In the latest 0.10-SNAPSHOT, we have removed log4j from the fat jar.

Can you copy everything from the lib/ folder from your maven build into the
lib/ folder of your flink installation?
Log4j is now in a separate jar in the lib/ folder .

What about the curator dependency issue?

On Wed, Oct 14, 2015 at 4:56 PM, Gwenhael Pasquiers <
gwenhael.pasquiers@ericsson.com> wrote:

> The first class that it can not find is :
>
> org.apache.log4j.Level
>
>
>
> The org.apache.log4j package is not present in the fat jar I get from the
> mvn command, but it is in the one you distributed on your website.
>
>
>
> *From:* Robert Metzger [mailto:rmetzger@apache.org]
> *Sent:* mercredi 14 octobre 2015 16:54
> *To:* user@flink.apache.org
> *Subject:* Re: Building Flink with hadoop 2.6
>
>
>
> Great.
>
> Which classes can it not find at runtime?
>
>
>
> I'll try to build and run Flink with exactly the command you've provided.
>
>
>
> On Wed, Oct 14, 2015 at 4:49 PM, Gwenhael Pasquiers <
> gwenhael.pasquiers@ericsson.com> wrote:
>
> Hi Robert !
>
>
>
> I’m using ” mvn clean install -DskipTests -Dhadoop.version=2.6.0 “.
>
>
>
>
>
> *From:* Robert Metzger [mailto:rmetzger@apache.org]
> *Sent:* mercredi 14 octobre 2015 16:47
> *To:* user@flink.apache.org
> *Subject:* Re: Building Flink with hadoop 2.6
>
>
>
> Hi Gwen,
>
>
>
> can you tell us the "mvn" command you're using for building Flink?
>
>
>
>
>
>
>
> On Wed, Oct 14, 2015 at 4:37 PM, Gwenhael Pasquiers <
> gwenhael.pasquiers@ericsson.com> wrote:
>
> Hi ;
>
>
>
> We need to test some things with flink and hadoop 2.6 (the trunc method).
>
>
>
> We’ve set up a build task on our Jenkins and everything seem okay.
>
>
>
> However when we replace the original jar from your 0.10-SNAPSHOT
> distribution by ours there are some missing dependencies (log4j, curator,
> and maybe others) and we get some ClassNotFoundException at runtime.
>
>
>
> Are we missing some build parameters ?
>
>
>
> Thanks in advance,
>
>
>
> B.R.
>
>
>
>
>

Mime
View raw message