flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maximilian Michels <...@apache.org>
Subject Re: problem with union
Date Wed, 15 Jul 2015 09:33:22 GMT
Hi Michele,

Thanks for reporting the problem. It seems like we changed the way we
compare generic types like your GValue type. I'm debugging that now. We can
get a fix in for the 0.9.1 release.

Cheers,
Max

On Tue, Jul 14, 2015 at 5:35 PM, Michele Bertoni <
michele1.bertoni@mail.polimi.it> wrote:

> Hi everybody, this discussion started in an other thread about a problem
> in union, but you said it was a different error then i am opening a new
> topic
>
> I am doing the union of two dataset and I am getting this error
>
>
>
>
> Exception in thread "main"
> org.apache.flink.api.common.InvalidProgramException: Cannot union inputs of
> different types. Input1=scala.Tuple6(_1: Long, _2: String, _3: Long, _4:
> Long, _5: Character, _6:
> ObjectArrayTypeInfo<GenericType<it.polimi.genomics.core.DataTypes.GValue>>),
> input2=scala.Tuple6(_1: Long, _2: String, _3: Long, _4: Long, _5:
> Character, _6:
> ObjectArrayTypeInfo<GenericType<it.polimi.genomics.core.DataTypes.GValue>>)
>         at
> org.apache.flink.api.java.operators.UnionOperator.<init>(UnionOperator.java:46)
>         at org.apache.flink.api.scala.DataSet.union(DataSet.scala:1101)
>         at
> it.polimi.genomics.flink.FlinkImplementation.operator.region.GenometricCover2$.apply(GenometricCover2.scala:125)
>         ...
>
>
>
>
> Input1=
> scala.Tuple6(_1: Long, _2: String, _3: Long, _4: Long, _5: Character, _6:
> ObjectArrayTypeInfo<GenericType<it.polimi.genomics.core.DataTypes.GValue>>)
> input2=
> scala.Tuple6(_1: Long, _2: String, _3: Long, _4: Long, _5: Character, _6:
> ObjectArrayTypeInfo<GenericType<it.polimi.genomics.core.DataTypes.GValue>>)
>
>
> as you can see the two datasets have the same type
> this error only happens with a custom data type (e.g. i am using an array
> of GValue, an array of Int or Double works)
>
> in the last flink version it was working (milestone and snapshot) now in
> 0.9.0 it is not
>
> what can it be?
>
>
> thanks for help
>
> cheers,
> Michele

Mime
View raw message