flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Till Rohrmann <till.rohrm...@gmail.com>
Subject Re: Flink 0.9 built with Scala 2.11
Date Wed, 10 Jun 2015 13:20:16 GMT
No there are no Scala 2.11 Flink binaries which you can download. You have
to build it yourself.

Cheers,
Till

On Wed, Jun 10, 2015 at 3:19 PM Philipp Goetze <philipp.goetze@tu-ilmenau.de>
wrote:

> Thank you Chiwan!
>
> I did not know the master has a 2.11 profile.
>
> But there is no pre-built Flink with 2.11, which I could refer to in sbt
> or maven, is it?
>
> Best Regards,
> Philipp
>
> On 10.06.2015 15:03, Chiwan Park wrote:
> > Hi. You can build Flink with Scala 2.11 with scala-2.11 profile in
> master branch.
> > `mvn clean install -DskipTests -P \!scala-2.10,scala-2.11` command
> builds Flink with Scala 2.11.
> >
> > Regards,
> > Chiwan Park
> >
> >> On Jun 10, 2015, at 9:56 PM, Flavio Pompermaier <pompermaier@okkam.it>
> wrote:
> >>
> >> Nice!
> >>
> >> On 10 Jun 2015 14:49, "Philipp Goetze" <philipp.goetze@tu-ilmenau.de>
> wrote:
> >> Hi community!
> >>
> >> We started a new project called Piglet (
> https://github.com/ksattler/piglet).
> >> For that we use i.a. Flink as a backend. The project is based on Scala
> 2.11. Thus we need a 2.11 build of Flink.
> >>
> >> Until now we used the 2.11 branch of the stratosphere project and built
> Flink ourselves. Unfortunately this branch is not up-to-date.
> >>
> >> Do you have an official repository for Flink 0.9 (built with Scala
> 2.11)?
> >>
> >> Best Regards,
> >> Philipp
> >
> >
> >
> >
>
>

Mime
View raw message