flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maximilian Alber <alber.maximil...@gmail.com>
Subject Building Yarn-Version of Flink
Date Tue, 23 Jun 2015 12:03:41 GMT
Hi Flinksters,

I just tried to build the current yarn version of Flink. The second error
is probably a because maven is of an older version. But the first one seems
to be an error.

albermax@hadoop1:~/bumpboost/working/programs/flink/incubator-flink$ mvn
clean package -DskipTests -Dhadoop.profile=2
[INFO] Scanning for projects...
[ERROR] The build could not read 2 projects -> [Help 1]
[ERROR]
[ERROR]   The project org.apache.flink:flink-shaded-hadoop:0.10-SNAPSHOT
(/home/albermax/bumpboost/working/programs/flink/incubator-flink/flink-shaded-hadoop/pom.xml)
has 1 error
[ERROR]     Child module
/home/albermax/bumpboost/working/programs/flink/incubator-flink/flink-shaded-hadoop/error
of
/home/albermax/bumpboost/working/programs/flink/incubator-flink/flink-shaded-hadoop/pom.xml
does not exist
[ERROR]
[ERROR]   The project org.apache.flink:flink-hbase:0.10-SNAPSHOT
(/home/albermax/bumpboost/working/programs/flink/incubator-flink/flink-staging/flink-hbase/pom.xml)
has 1 error
[ERROR]     'dependencies.dependency.version' for
org.apache.hbase:hbase-server:jar must be a valid version but is
'${hbase.version}'. @ line 97, column 13
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e
switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the following articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException


Thanks!
Cheers,
Max

Mime
View raw message