flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bunk <stefan.b...@googlemail.com>
Subject Re: Logging in Flink 0.9.0-milestone-1
Date Tue, 14 Apr 2015 17:02:19 GMT
Hi,

I am also using IntelliJ, and I am starting directly from the IDE. Local
execution.
This is what my logging output looks like: [1].

I am getting my logger via:
val log = org.apache.log4j.Logger.getLogger(getClass)

[1] https://gist.github.com/knub/1c11683601b4eeb5d51b

On 14 April 2015 at 18:47, Robert Metzger <rmetzger@apache.org> wrote:

> Hi,
>
> how are you starting Flink? Out of the IDE? Using the scripts?
>
> I just created a new flink project with the milestone version. Just
> putting your log4j.xml into the resources folder enabled the logging (I've
> set it to INFO for flink and it worked).
> I've used IntelliJ and started the WordCount.java from the quickstart.
>
> I think I need more details about your setup to reproduce the issue.
>
>
>
>
> On Tue, Apr 14, 2015 at 5:52 PM, Stefan Bunk <stefan.bunk@googlemail.com>
> wrote:
>
>> Hi Robert,
>>
>> thanks for the info.
>> Adding the parameter didn't help. My logging file is found and my logging
>> configuration for my own logging is working (even without the parameter),
>> it's just that the file in the jar seems to be preferred over my file.
>>
>> Best,
>> Stefan
>>
>> On 14 April 2015 at 17:16, Robert Metzger <rmetzger@apache.org> wrote:
>>
>>> Hi Stefan,
>>>
>>> we made a stupid mistake in the 0.9.0-milestone-1 release by including
>>> our log4j.properties into the flink-runtime jar. its also in the fat jar in
>>> flink-dist.
>>>
>>> Maybe you can pass the name of your log4j file to your application with
>>> -Dlog4j.configuration=log4j.xml?
>>>
>>> The issue is already fixed in the current master but that doesn't help
>>> 0.9.0-milestone-1 users :(
>>>
>>> Best,
>>> Robert
>>>
>>> On Tue, Apr 14, 2015 at 4:49 PM, Stefan Bunk <stefan.bunk@googlemail.com
>>> > wrote:
>>>
>>>> Hi Flinkers,
>>>>
>>>> I just switched to 0.9.0-milestone-1, and now I get Flink's logging
>>>> output again in my console (local execution).
>>>> I have a log4j.xml under src/main/resources, which says not to log any
>>>> Flink job progress updates, and which worked fine so far:
>>>>
>>>> [...]
>>>> <logger name="org.apache.flink">
>>>>                 <level value="ERROR" />
>>>>                 <appender-ref ref="Console" />
>>>> </logger>
>>>> [...]
>>>> See the full file at [1].
>>>>
>>>> However, this file seems to be ignored now. What do I need to change?
>>>>
>>>> Cheers
>>>> Stefan
>>>>
>>>> [1] https://gist.github.com/knub/bb1b3ffc6b47e2a1376d
>>>>
>>>
>>>
>>
>

Mime
View raw message