flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From HungChang <unicorn.bana...@gmail.com>
Subject error in reduceGroup operator when changing the Flink version from 0.7 to 0.8
Date Tue, 24 Feb 2015 09:50:14 GMT
Hi, when changing the version from 0.7 to 0.8, reduceGroup operator gets the
following error:

"The method reduceGroup(GroupReduceFunction<Tuple,R>) in the type
DataSet<Tuple> is not applicable for the arguments
(InDegreeDistribution.CountVertices)"

Tried to figure out the error but failed to fix it. Could you please give
some suggestions?

The code is as follows:
-------------------------------------------------------------------------------------------------------------
DataSet<Long> numVertices edges.project(1)).distinct().reduceGroup(new
CountVertices())

public static class CountVertices implements
			GroupReduceFunction<Tuple1&lt;Long>, Long> {
		@Override
		public void reduce(Iterable<Tuple1&lt;Long>> vertices,
				Collector<Long> collector) throws Exception {
			collector.collect(new Long(Iterables.size(vertices)));
		}
	}

Best regards,

Hung



--
View this message in context: http://apache-flink-incubator-user-mailing-list-archive.2336050.n4.nabble.com/error-in-reduceGroup-operator-when-changing-the-Flink-version-from-0-7-to-0-8-tp785.html
Sent from the Apache Flink (Incubator) User Mailing List archive. mailing list archive at
Nabble.com.

Mime
View raw message