flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Viktor Rosenfeld <viktor.rosenf...@tu-berlin.de>
Subject Re: Wrong and non consistent behavior of max
Date Fri, 28 Nov 2014 17:23:36 GMT

I would drop min/max/sum. I've marked them deprecated in my pull request
because I did not change their current implementation based on the old

I think that it makes more sense to have convenience functions like
countByKey which Sebastian suggested that do encapsulate more complex
behavior than an aggregation on a single field.

I would also rename minBy/maxBy to selectMin/selectMax or something similar
(selectMinBy?, selectMinByField?) to make their behavior more explicit.


View this message in context: http://apache-flink-incubator-user-mailing-list-archive.2336050.n4.nabble.com/Wrong-and-non-consistent-behavior-of-max-tp484p499.html
Sent from the Apache Flink (Incubator) User Mailing List archive. mailing list archive at

View raw message