flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Metzger <rmetz...@apache.org>
Subject Re: HBase 0.7.0 addon
Date Fri, 31 Oct 2014 05:19:00 GMT
Okay, I've deployed the missing artifacts to maven central. it will take
some hours until they are synchronized.
The example in the "flink-hbase" module is still using the old Java API.
But you should be able to use the Hbase Input format like this:
        ExecutionEnvironment ee =
ExecutionEnvironment.getExecutionEnvironment();
        DataSet<Record> t = ee.createInput(new MyTableInputFormat());

I think the Flink Hbase module is not very well-tested, so its likely that
you'll find issues while using it.

The only documentation on logging we have is this one:
http://flink.incubator.apache.org/docs/0.7-incubating/internal_logging.html

Are you only seeing the log messages from Flink or no messages at all?


On Thu, Oct 30, 2014 at 4:10 PM, Flavio Pompermaier <pompermaier@okkam.it>
wrote:

> Ok thanks!I was trying to run a mapreduce flink job using an hbase dataset
> but I wasn't able to make it run it locally. The one in the addons just
> specify a plan but it does not say how to test it.
> Moreover I tried to put a log4j.properties in the classpath to debug
> what's going on but I can't see any debug info. Do you have any hook/guide?
> On Oct 30, 2014 11:58 PM, "Robert Metzger" <rmetzger@apache.org> wrote:
>
>> Hi,
>>
>> No, there is no reason for that. It actually seems like something went
>> wrong while releasing Flink 0.7.0. I'll deploy the missing artifacts.
>>
>> On Thu, Oct 30, 2014 at 9:26 AM, Flavio Pompermaier <pompermaier@okkam.it
>> > wrote:
>>
>>> Hi to all,
>>>
>>> is there a reason why the 0.7.0 hbase addons is not deployed on maven
>>> central?
>>>
>>> Thanks in advance,
>>> Flavio
>>>
>>
>>

Mime
View raw message