flink-user-zh mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 宇张 <zhan...@akulaku.com>
Subject Re: flink1.10关于jar包冲突问题
Date Wed, 22 Apr 2020 09:35:22 GMT
好的,接下来工程中我会把 不需要的传递依赖都应该 exclude 掉,而遇到的jar包冲突问题会进行记录,感谢解疑

On Wed, Apr 22, 2020 at 2:16 PM tison <wander4096@gmail.com> wrote:

> 能具体看一下报错吗?一般来说 Flink 自己需要的依赖都会 shaded 起来,不需要的传递依赖都应该
exclude 掉。暴露成 API
> 的类别一般需要封装或者使用稳定的接口。
>
> 这可能是一个工程上的问题,你可以具体罗列一下遇到的 JAR 包冲突问题,看一下怎么解。
>
> Best,
> tison.
>
>
> 宇张 <zhangyu@akulaku.com> 于2020年4月22日周三 上午11:52写道:
>
> > 在使用Flink1.10时,遇到最多的问题就是jar包冲突问题,okio这个包flink-parent引用的就有四个版本,还有一些没办法<
> > exclusions>的包,请问社区有没有优化jar包冲突的提议。。。。。
> >
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message