flink-user-zh mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yun Gao" <yungao...@aliyun.com.INVALID>
Subject Re: 关于Flink1.10.0 flink-hbase guava依赖冲突问题
Date Thu, 09 Apr 2020 13:34:26 GMT
现在的现象是作业运行起来会有报错么?能发一下pom和大体的作业的样子不?


------------------------------------------------------------------
From:111 <xinghalo@163.com>
Send Time:2020 Apr. 9 (Thu.) 14:31
To:user-zh@flink.apache.org <user-zh@flink.apache.org>
Subject:关于Flink1.10.0 flink-hbase guava依赖冲突问题

Hi,
我这边发现hbase-connector模块对guava的依赖有冲突:


首先flink中的calcite需要guava是16以上的版本(低版本没有这个类),因为要使用:com/google/common/collect/MultimapBuilder$SortedSetMultimapBuilder
其次HBase需要guava12.0版本(更高的版本就移除这个方法了),因为要使用:com.google.common.hash.HashFunction.hashString(Ljava/lang/CharSequence;)Lcom/google/common/hash/HashCode;


不知道官方在使用单元测试时,是否有什么特殊的配置能规避这个问题?


Best,
Xinghalo
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message