flink-user-zh mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benchao Li <libenc...@gmail.com>
Subject Re: flink on yarn jdk版本问题
Date Wed, 15 Jan 2020 04:56:47 GMT
Hi ,

Flink也支持传递环境变量的,也可以尝试一下:
https://ci.apache.org/projects/flink/flink-docs-master/ops/config.html#configuration-runtime-environment-variables

郑 洁锋 <zjfplayer@hotmail.com> 于2020年1月15日周三 上午11:34写道:

> Hi,
>
> 我们使用了TDH中的yarn(hadoop2.7,jdk1.7),原先使用spark的时候,也遇到过jdk版本最低1.8的情况,我们是通过如下方式解决的(考虑到现场公用TDH集群不能更改):
>         spark-submit中可以通过添加参数 --conf
> "spark.yarn.appMasterEnv.JAVA_HOME=/usr/java/jdk1.8.0_25/" --conf
> "spark.executorEnv.JAVA_HOME=/usr/java/jdk1.8.0_25/"来指定当前spark任务特定在yarn中执行时的jdk目录
>
>         请问下flink启动&提交任务时(bin/yarn-session.sh&flink
> run)有没有参数可以指定flink特定使用yarn时的jdk目录,flink中是否有这样的功能?(不影响其他yarn上应用正常运行)
>
>
>
> ________________________________
> zjfplayer@hotmail.com
>


-- 

Benchao Li
School of Electronics Engineering and Computer Science, Peking University
Tel:+86-15650713730
Email: libenchao@gmail.com; libenchao@pku.edu.cn
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message