flink-user-zh mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 李军 <hold_li...@163.com>
Subject 回复: yarn-session.sh 启动 报错
Date Mon, 18 Nov 2019 08:44:37 GMT
找到问题了;
是我这个包:flink-shaded-hadoop-2-uber-2.8.3-7.0 (1)  名字错了;
但是又有一个错误不是很明白;




签名由网易邮箱大师定制
在2019年11月18日 16:38,李军<hold_lijun@163.com> 写道:
HADOOP_CLASSPATH 设置了;
启动这个好像不需要指定程序的入口类吧




在2019年11月18日 16:34,tison<wander4096@gmail.com> 写道:
可能是你没有设置 HADOOP_CLASSPATH

参考 https://flink.apache.org/downloads.html 本页面最上部分

If you plan to use Apache Flink together with Apache Hadoop (run Flink on
YARN, connect to HDFS, connect to HBase, or use some Hadoop-based file
system connector) then select the download that bundles the matching Hadoop
version, download the optional pre-bundled Hadoop that matches your version
and place it in the lib folder of Flink, or export your HADOOP_CLASSPATH
<https://ci.apache.org/projects/flink/flink-docs-stable/ops/deployment/hadoop.html>

Best,
tison.


李军 <hold_lijun@163.com> 于2019年11月18日周一 下午4:31写道:

启动命令:         ./bin/yarn-session.sh -n 2 -jm 1024 -tm 1024
报错:Error: Could not find or load main class
org.apache.flink.yarn.cli.FlinkYarnSessionCli


ResourceManager,NodeManager都已启动。
Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message