flink-user-zh mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From renc law <lawrence...@icloud.com.INVALID>
Subject Re: flink1.9.1编译hadoop版本3.0.0-cdh6.0.1,on yarn报错
Date Fri, 25 Oct 2019 05:13:15 GMT

老铁可以分享下编译部署的经验么,最近也打算在cdh的6.2.0上装套1.8.1的

> 在 2019年10月25日,上午10:31,homex wu <whx403@gmail.com> 写道:
> 
> 
> 权限问题,乌龙了。😂
> 
> homex wu <whx403@gmail.com> 于2019年10月25日周五 上午9:42写道:
>> 场景:从1.8开始编译的hadoop版本为3.0.0-cdh6.0.1的,执行./bin/yarn-session.sh
-tm 1024 -s 4
>> 开始会报错,退回1.7.2就正常了,现在用1.9.1版本编译的3.0.0-cdh6.0.1,执行on
yarn还是报错,
>> 是否是hadoop版本有问题呢?
>> 
>> 已设置环境变量:
>> export HADOOP_CLASSPATH=/opt/cloudera/parcels/CDH/lib/hadoop/lib
>> export HADOOP_CONF_DIR=/etc/hadoop/conf
>> 
>> lib下的包:
>> 
>> 
>> 
>> 部分错误日志(全部日志见附件):
>> 
Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message