flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "godfrey he (Jira)" <j...@apache.org>
Subject [jira] [Updated] (FLINK-15298) Wrong dependencies in the DataStream API tutorial (the wiki-edits example)
Date Wed, 14 Jul 2021 06:50:00 GMT

     [ https://issues.apache.org/jira/browse/FLINK-15298?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

godfrey he updated FLINK-15298:
-------------------------------
    Fix Version/s:     (was: 1.11.4)
                   1.11.5

> Wrong dependencies in the DataStream API tutorial (the wiki-edits example)
> --------------------------------------------------------------------------
>
>                 Key: FLINK-15298
>                 URL: https://issues.apache.org/jira/browse/FLINK-15298
>             Project: Flink
>          Issue Type: Bug
>          Components: API / DataStream, Documentation
>    Affects Versions: 1.7.2, 1.8.3, 1.9.1
>            Reporter: Jun Qin
>            Priority: Minor
>              Labels: auto-deprioritized-major, auto-unassigned, pull-request-available
>             Fix For: 1.10.4, 1.14.0, 1.11.5
>
>          Time Spent: 10m
>  Remaining Estimate: 0h
>
> [The DataStream API Tutorial in Flink 1.9 | https://ci.apache.org/projects/flink/flink-docs-release-1.9/getting-started/tutorials/datastream_api.html]
mentioned the following dependences:
> {code:java}
> <dependencies>
>     <dependency>
>         <groupId>org.apache.flink</groupId>
>         <artifactId>flink-java</artifactId>
>         <version>${flink.version}</version>
>     </dependency>
>     <dependency>
>         <groupId>org.apache.flink</groupId>
>         <artifactId>flink-streaming-java_2.11</artifactId>
>         <version>${flink.version}</version>
>     </dependency>
>     <dependency>
>         <groupId>org.apache.flink</groupId>
>         <artifactId>flink-clients_2.11</artifactId>
>         <version>${flink.version}</version>
>     </dependency>
>     <dependency>
>         <groupId>org.apache.flink</groupId>
>         <artifactId>flink-connector-wikiedits_2.11</artifactId>
>         <version>${flink.version}</version>
>     </dependency>
> </dependencies>
> {code}
> There are two issues here:
> # {{flink-java}} and {{flink-streaming-java}} should be set to *provided* scope
> # {{flink-client}} is not needed. If {{flink-client}} is added into *compile* scope,
{{flink-runtime}} will be added implicitly



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message