flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chesnay Schepler (Jira)" <j...@apache.org>
Subject [jira] [Updated] (FLINK-17059) flink-shaded-hadoop-2-uber:2.8.3-10.0 has invalid pom in Gradle
Date Wed, 08 Apr 2020 21:33:00 GMT

     [ https://issues.apache.org/jira/browse/FLINK-17059?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chesnay Schepler updated FLINK-17059:
-------------------------------------
    Affects Version/s:     (was: 1.10.0)
                       shaded-10.0

> flink-shaded-hadoop-2-uber:2.8.3-10.0 has invalid pom in Gradle
> ---------------------------------------------------------------
>
>                 Key: FLINK-17059
>                 URL: https://issues.apache.org/jira/browse/FLINK-17059
>             Project: Flink
>          Issue Type: Bug
>          Components: BuildSystem / Shaded
>    Affects Versions: shaded-10.0
>            Reporter: John Lonergan
>            Priority: Major
>
> The uploaded pom for flink-shaded-hadoop-2-uber:2.8.3-10.0 has invalid pom 
> has a variable in the artefact version field.
> That version is being populated from the parent pom where hadoop.version=2.4.1
> This means the then internal model for this pom when it's loaded says its v 2.4.1 but
the external file version says 2.8.3
> This means that when Gradle loads the artefact it barfs about bad metadata and refuses
the artefact.
> Can't use this series of jars in gradle - except for the actual 2.4.1 instance.
> Easy to reproduce - just create a gradle dependency on the 2.8.3 variant.
> --
> I guess this situation might be on in mvn??
> Suggest a test is added that attempts to consume these artefacts in other common build
tools.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message