flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabian Wollert (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FLINK-10706) Update the Flink Dashboard and its components
Date Tue, 06 Nov 2018 08:11:00 GMT

     [ https://issues.apache.org/jira/browse/FLINK-10706?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Fabian Wollert updated FLINK-10706:
-----------------------------------
    Description: 
The Flink Dashboard uses currently Angular 1, which had its successor coming out two years
ago. Its expected that Angular 1 (or Angular.js how it is called now) will ceise to exist
in the future, due to its successor Angular 2-7 and React being the more actively developed
platforms.

We should move to Angular 7 or React.

  was:
The Flink Dashboard uses currently Angular 1, which had its successor coming out two years
ago. Its expected that Angular 1 (or Angular.js how it is called now) will ceise to exist
in the future, due to its successor Angular 2-7 and React being the more actively developed
platforms.

Due to my personal experience with React i will attempt to rewrite the Dashboard in React.
Additionally i will upgrade all used libs, which mostly affects Bootstrap 4, hence the look
will be slightly different.

        Summary: Update the Flink Dashboard and its components  (was: Rewrite Flink Dashboard
with React)

> Update the Flink Dashboard and its components
> ---------------------------------------------
>
>                 Key: FLINK-10706
>                 URL: https://issues.apache.org/jira/browse/FLINK-10706
>             Project: Flink
>          Issue Type: Sub-task
>          Components: Webfrontend
>    Affects Versions: 1.6.2
>            Reporter: Fabian Wollert
>            Assignee: Fabian Wollert
>            Priority: Major
>             Fix For: 1.8.0
>
>
> The Flink Dashboard uses currently Angular 1, which had its successor coming out two
years ago. Its expected that Angular 1 (or Angular.js how it is called now) will ceise to
exist in the future, due to its successor Angular 2-7 and React being the more actively developed
platforms.
> We should move to Angular 7 or React.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message