flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] pnowojski commented on a change in pull request #6889: [FLINK-10599][Documentation] Provide documentation for the modern kafka connector
Date Thu, 25 Oct 2018 12:34:44 GMT
pnowojski commented on a change in pull request #6889: [FLINK-10599][Documentation] Provide
documentation for the modern kafka connector
URL: https://github.com/apache/flink/pull/6889#discussion_r228151680
 
 

 ##########
 File path: docs/dev/connectors/kafka.md
 ##########
 @@ -100,6 +108,30 @@ Note that the streaming connectors are currently not part of the binary
distribu
 * Follow the instructions from [Kafka's quickstart](https://kafka.apache.org/documentation.html#quickstart)
to download the code and launch a server (launching a Zookeeper and a Kafka server is required
every time before starting the application).
 * If the Kafka and Zookeeper servers are running on a remote machine, then the `advertised.host.name`
setting in the `config/server.properties` file must be set to the machine's IP address.
 
+## Modern Kafka Connector
+
+Starting with Flink 1.7, there is a new Kafka connector that does not track a specific Kafka
major version. Rather, it tracks the latest version of Kafka at the time of the Flink release.
+
+If your Kafka broker version is 1.0.0 or newer, you should use this Kafka connector. If you
use an older version of Kafka (0.11, 0.10, 0.9, or 0.8), you should use the connector corresponding
to the broker version.
+
+### Compatibility
+
+The modern Kafka connector is compatible with older and newer Kafka brokers through the compatibility
guarantees of the Kafka client API and broker. The modern Kafka client is compatible with
broker versions 0.10.0 or later, depending on the features used. For details on Kafka compatibility,
please refer to the [Kafka documentation](https://kafka.apache.org/protocol.html#protocol_compatibility).
 
 Review comment:
   Have we tested that this new connector works with Kafka 0.10? Definitely not in `exacty_once`
mode. Maybe it does work with `at_least_once` mode, but if we haven't tested that, I would
refrain from saying it. So I would rephrase this to:
   
   ```
   The modern Kafka connector is compatible with broker versions 0.11.0 or later
   ```

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message