flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabian Hueske (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-9448) contribute-code.html references Hadoop 1.x support
Date Tue, 05 Jun 2018 08:29:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-9448?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16501470#comment-16501470
] 

Fabian Hueske commented on FLINK-9448:
--------------------------------------

Thanks for noticing and reporting this!

While we are at it, Flink also requires Java 1.8 to compile by now.

Best, Fabian

> contribute-code.html references Hadoop 1.x support
> --------------------------------------------------
>
>                 Key: FLINK-9448
>                 URL: https://issues.apache.org/jira/browse/FLINK-9448
>             Project: Flink
>          Issue Type: Bug
>          Components: Project Website
>            Reporter: Andrew Janke
>            Assignee: vinoyang
>            Priority: Minor
>
> In the Contribute Code page on the website, it references Hadoop 1.x support under "How
to use Git as a committer" and "Snapshots (Nightly Builds)"
> > If you want to build for Hadoop 1, activate the build profile via mvn clean package
-DskipTests -Dhadoop.profile=1.
> > ...
> > You can now include Apache Flink as a Maven dependency (see above) with version
1.6-SNAPSHOT (or `` for compatibility with old Hadoop 1.x versions).
> That snapshot reference includes the Markdown code:
> (or `{{ site.FLINK_VERSION_HADOOP_1_LATEST}}` for compatibility with old Hadoop 1.x versions)
> but there's no definition in config.yml for FLINK_VERSION_HADOOP_1_LATEST. And looking
through the other docs, it seems like only Hadoop 2.x is supported at this point.
> Is Hadoop 1.x still supported? And if not, should these references be removed?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message