flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cliff Resnick (JIRA)" <j...@apache.org>
Subject [jira] [Created] (FLINK-9339) Accumulators are not UI accessible running in FLIP-6 mode
Date Fri, 11 May 2018 18:18:00 GMT
Cliff Resnick created FLINK-9339:
------------------------------------

             Summary: Accumulators are not UI accessible running in FLIP-6 mode
                 Key: FLINK-9339
                 URL: https://issues.apache.org/jira/browse/FLINK-9339
             Project: Flink
          Issue Type: Bug
          Components: REST
    Affects Versions: 1.5.0
            Reporter: Cliff Resnick


Using 1.5-rc2, when I run a job in flip-6 mode and try to access Accumulators in the UI nothing
shows. Looking at the Job manager log there is this error: 
 
2018-05-11 17:09:04,707 ERROR org.apache.flink.runtime.rest.handler.job.SubtaskCurrentAttemptDetailsHandler
 - Could not create the handler request.
org.apache.flink.runtime.rest.handler.HandlerRequestException: Cannot resolve path parameter
(subtaskindex) from value "accumulators".
	at org.apache.flink.runtime.rest.handler.HandlerRequest.<init>(HandlerRequest.java:61)
	at org.apache.flink.runtime.rest.AbstractHandler.respondAsLeader(AbstractHandler.java:155)
	at org.apache.flink.runtime.rest.handler.RedirectHandler.lambda$null$0(RedirectHandler.java:139)
	at java.util.concurrent.CompletableFuture.uniWhenComplete(CompletableFuture.java:760)
	at java.util.concurrent.CompletableFuture$UniWhenComplete.tryFire(CompletableFuture.java:736)
	at java.util.concurrent.CompletableFuture$Completion.run(CompletableFuture.java:442)
	at org.apache.flink.shaded.netty4.io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:357)
	at org.apache.flink.shaded.netty4.io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:357)
	at org.apache.flink.shaded.netty4.io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:111)
	at org.apache.flink.shaded.netty4.io.netty.util.concurrent.DefaultThreadFactory$DefaultRunnableDecorator.run(DefaultThreadFactory.java:137)
	at java.lang.Thread.run(Thread.java:748)
 
This error does not occur when running the same job in legacy mode.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message