flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-8645) Support convenient extension of parent-first ClassLoader patterns
Date Wed, 21 Feb 2018 14:51:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-8645?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16371503#comment-16371503

ASF GitHub Bot commented on FLINK-8645:

Github user StephanEwen commented on the issue:

    Good change in principle, but I think "base" and "append" are not a great choice of names
for the parameters. Probably not very intuitive for users.
    How about calling them `default` and `additional`?
    While at it, should we also rename the `ALWAYS_PARENT_FIRST_LOADER` config key name? Calling

> Support convenient extension of parent-first ClassLoader patterns
> -----------------------------------------------------------------
>                 Key: FLINK-8645
>                 URL: https://issues.apache.org/jira/browse/FLINK-8645
>             Project: Flink
>          Issue Type: Improvement
>          Components: Configuration
>    Affects Versions: 1.5.0
>            Reporter: Chesnay Schepler
>            Assignee: Chesnay Schepler
>            Priority: Major
> The option {{classloader.parent-first-patterns}} defines a list of class pattern that
should always be loaded through the parent class-loader. The default value contains all classes
that are effectively required to be loaded that way for Flink to function.
> This list cannot be extended in a convenient way, as one would have to manually copy
the existing default and append new entries. This makes the configuration brittle in light
of version upgrades where we may extend the default, and also obfuscates the configuration
a bit.
> I propose to separate this option into {{classloader.parent-first-patterns.base}}, which
subsumes the existing option, and {{classloader.parent-first-patterns.append}} which is automatically
appended to the base.

This message was sent by Atlassian JIRA

View raw message