flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephan Ewen (JIRA)" <j...@apache.org>
Subject [jira] [Created] (FLINK-7924) Fix incorrect names of checkpoint options
Date Wed, 25 Oct 2017 18:47:00 GMT
Stephan Ewen created FLINK-7924:

             Summary: Fix incorrect names of checkpoint options
                 Key: FLINK-7924
                 URL: https://issues.apache.org/jira/browse/FLINK-7924
             Project: Flink
          Issue Type: Sub-task
          Components: State Backends, Checkpointing
            Reporter: Stephan Ewen
            Assignee: Stephan Ewen
             Fix For: 1.4.0

Checkpoint options are incorrectly always called 'FULL_CHECKPOINT' when actually,
the checkpoints may always be incremental and only savepoints have to be full
and self contained.

Initially, we planned to add options for multiple checkpoints, like checkpoints
that were foreced to be full, and checkpoints that were incremental. That 
is not necessary at this point.

This message was sent by Atlassian JIRA

View raw message