flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chesnay Schepler (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-5233) Upgrade Jackson version because of class loader leak
Date Mon, 14 Aug 2017 08:51:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-5233?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16125405#comment-16125405
] 

Chesnay Schepler commented on FLINK-5233:
-----------------------------------------

We are still using 2.7.4. We could bump the version to 2.7.9 when creating the jackson dependency
for flink-shaded.

> Upgrade Jackson version because of class loader leak
> ----------------------------------------------------
>
>                 Key: FLINK-5233
>                 URL: https://issues.apache.org/jira/browse/FLINK-5233
>             Project: Flink
>          Issue Type: Bug
>          Components: Local Runtime
>    Affects Versions: 1.1.3
>            Reporter: Robert Metzger
>            Assignee: Robert Metzger
>            Priority: Critical
>
> A user reported this issue on the ML:
> http://apache-flink-user-mailing-list-archive.2336050.n4.nabble.com/Flink-1-1-3-OOME-Permgen-td10379.html
> I propose to upgrade to Jackson 2.7.8, as this version contains the fix for the issue,
but its not a major jackson upgrade.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message