flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-6951) Incompatible versions of httpcomponents jars for Flink kinesis connector
Date Mon, 10 Jul 2017 19:15:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-6951?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16080911#comment-16080911
] 

ASF GitHub Bot commented on FLINK-6951:
---------------------------------------

Github user bowenli86 commented on the issue:

    https://github.com/apache/flink/pull/4150
  
    @tzulitai @tedyu 
    
    Hi guys, I'm also wondering how much percentage of Flink users are using Flink with Kinesis?
Kinesis has so many limitations that we are considering to move from Kinesis to Kafka. Knowing
general preference of Flink users will make us more confident in this move. I guess not a
lot people are using Flink + Kinesis, otherwise I won't be the first one running into this
dependency conflict bug. Do you guys have any numbers in mind?


> Incompatible versions of httpcomponents jars for Flink kinesis connector
> ------------------------------------------------------------------------
>
>                 Key: FLINK-6951
>                 URL: https://issues.apache.org/jira/browse/FLINK-6951
>             Project: Flink
>          Issue Type: Bug
>          Components: Kinesis Connector
>    Affects Versions: 1.3.0
>            Reporter: Ted Yu
>            Assignee: Bowen Li
>
> In the following thread, Bowen reported incompatible versions of httpcomponents jars
for Flink kinesis connector :
> http://search-hadoop.com/m/Flink/VkLeQN2m5EySpb1?subj=Re+Incompatible+Apache+Http+lib+in+Flink+kinesis+connector
> We should find a solution such that users don't have to change dependency version(s)
themselves when building Flink kinesis connector.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message