flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-6951) Incompatible versions of httpcomponents jars for Flink kinesis connector
Date Mon, 10 Jul 2017 19:13:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-6951?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16080907#comment-16080907
] 

ASF GitHub Bot commented on FLINK-6951:
---------------------------------------

Github user bowenli86 commented on a diff in the pull request:

    https://github.com/apache/flink/pull/4150#discussion_r126511039
  
    --- Diff: flink-connectors/flink-connector-kinesis/pom.xml ---
    @@ -36,6 +36,8 @@ under the License.
     		<aws.sdk.version>1.10.71</aws.sdk.version>
     		<aws.kinesis-kcl.version>1.6.2</aws.kinesis-kcl.version>
     		<aws.kinesis-kpl.version>0.10.2</aws.kinesis-kpl.version>
    +		<apache.httpclient.version>4.3.6</apache.httpclient.version>
    +		<apache.httpcore.version>4.3.3</apache.httpcore.version>
    --- End diff --
    
    yes.
    Here's the dependency tree:
    
    aws-java-sdk-kinesis 1.10.71
    aws-java-sdk-core 1.10.71
    httpclient 4.3.6
    httpcore 4.3.3


> Incompatible versions of httpcomponents jars for Flink kinesis connector
> ------------------------------------------------------------------------
>
>                 Key: FLINK-6951
>                 URL: https://issues.apache.org/jira/browse/FLINK-6951
>             Project: Flink
>          Issue Type: Bug
>          Components: Kinesis Connector
>    Affects Versions: 1.3.0
>            Reporter: Ted Yu
>            Assignee: Bowen Li
>
> In the following thread, Bowen reported incompatible versions of httpcomponents jars
for Flink kinesis connector :
> http://search-hadoop.com/m/Flink/VkLeQN2m5EySpb1?subj=Re+Incompatible+Apache+Http+lib+in+Flink+kinesis+connector
> We should find a solution such that users don't have to change dependency version(s)
themselves when building Flink kinesis connector.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message