flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-5851) Renaming AsyncCollector into ResultPromise/ResultFuture
Date Sun, 02 Jul 2017 15:20:01 GMT

    [ https://issues.apache.org/jira/browse/FLINK-5851?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16071686#comment-16071686

ASF GitHub Bot commented on FLINK-5851:

GitHub user zhangminglei opened a pull request:


    [FLINK-5851] [streaming API] Rename AsyncCollector into ResultFuture


You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/zhangminglei/flink flink-5851

Alternatively you can review and apply these changes as the patch at:


To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #4243
commit f51c741562fe7191fa6afe88479422d36d27a2ab
Author: zhangminglei <zml13856086071@163.com>
Date:   2017-07-02T15:14:21Z

    [FLINK-5851] [streaming API] Rename AsyncCollector into ResultFuture


> Renaming AsyncCollector into ResultPromise/ResultFuture
> -------------------------------------------------------
>                 Key: FLINK-5851
>                 URL: https://issues.apache.org/jira/browse/FLINK-5851
>             Project: Flink
>          Issue Type: Improvement
>          Components: DataStream API
>    Affects Versions: 1.2.0, 1.3.0
>            Reporter: Till Rohrmann
>             Fix For: 1.4.0
> Currently, the async I/O API gives an {{AsyncCollector}} to an {{AsyncFunction}} implementation.
The name does not really reflect what the {{AsyncCollector}} does since it does not collect
but is actually a one time completable future. Therefore, I propose to rename the {{AsyncCollector}}
into {{ResultPromise}} or {{ResultFuture}}. This is API changing.

This message was sent by Atlassian JIRA

View raw message