flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bowenli86 <...@git.apache.org>
Subject [GitHub] flink pull request #4150: [FLINK-6951] Incompatible versions of httpcomponen...
Date Thu, 13 Jul 2017 06:51:34 GMT
Github user bowenli86 commented on a diff in the pull request:

    --- Diff: flink-connectors/flink-connector-kinesis/pom.xml ---
    @@ -56,6 +58,18 @@ under the License.
    +		    <groupId>org.apache.httpcomponents</groupId>
    +		    <artifactId>httpclient</artifactId>
    +		    <version>${apache.httpclient.version}</version>
    +		</dependency>
    +		<dependency>
    +		    <groupId>org.apache.httpcomponents</groupId>
    +		    <artifactId>httpcore</artifactId>
    +		    <version>${apache.httpcore.version}</version>
    +		</dependency>
    --- End diff --
    To clarify a bit more:
    - hadoop-aws 2.7 depends on http-components 4.2.x
    - aws-java-sdk-kinesis 1.10.71, a core dependency of flink-kinesis-connector, depends
on http-components 4.3.x.
    Thus, we should include http-components 4.3 into flink-kinesis-connector so that users
won't worry about deciding http-components version if they use hadoop-aws and flink-kinesis-connector
at the same time.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.

View raw message