flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Hogan (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FLINK-6414) Use scala.binary.version in place of change-scala-version.sh
Date Thu, 08 Jun 2017 14:45:19 GMT

     [ https://issues.apache.org/jira/browse/FLINK-6414?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Greg Hogan updated FLINK-6414:
------------------------------
    Fix Version/s:     (was: 1.3.0)

> Use scala.binary.version in place of change-scala-version.sh
> ------------------------------------------------------------
>
>                 Key: FLINK-6414
>                 URL: https://issues.apache.org/jira/browse/FLINK-6414
>             Project: Flink
>          Issue Type: Improvement
>          Components: Build System
>    Affects Versions: 1.3.0
>            Reporter: Greg Hogan
>            Assignee: Greg Hogan
>             Fix For: 1.4.0
>
>
> Recent commits have failed to modify {{change-scala-version.sh}} resulting in broken
builds for {{scala-2.11}}. It looks like we can remove the need for this script by replacing
hard-coded references to the Scala version with Flink's maven variable {{scala.binary.version}}.
> I had initially realized that the change script is [only used for building|https://ci.apache.org/projects/flink/flink-docs-release-1.3/setup/building.html#scala-versions]
and not for switching the IDE environment.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message