flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-6338) SimpleStringUtils should be called StringValueUtils
Date Wed, 26 Apr 2017 17:25:04 GMT

    [ https://issues.apache.org/jira/browse/FLINK-6338?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15985197#comment-15985197

ASF GitHub Bot commented on FLINK-6338:

GitHub user huawei-flink opened a pull request:


    [FLINK-6338] Add support for DISTINCT into Code Generated Aggregations

    Thanks for contributing to Apache Flink. Before you open your pull request, please take
the following check list into consideration.
    If your changes take all of the items into account, feel free to open your pull request.
For more information and/or questions please refer to the [How To Contribute guide](http://flink.apache.org/how-to-contribute.html).
    In addition to going through the list, please provide a meaningful description of your
    - [ ] General
      - The pull request references the related JIRA issue ("[FLINK-XXX] Jira title text")
      - The pull request addresses only one issue
      - Each commit in the PR has a meaningful commit message (including the JIRA id)
    - [ ] Documentation
      - Documentation has been added for new functionality
      - Old documentation affected by the pull request has been updated
      - JavaDoc for public methods has been added
    - [ ] Tests & Build
      - Functionality added by the pull request is covered by tests
      - `mvn clean verify` has been executed successfully locally or a Travis build has passed

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/stefanobortoli/flink FLINK-6338

Alternatively you can review and apply these changes as the patch at:


To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #3783
commit 55e0a8d38187bef22b6135db7f4a5c1cc8f15811
Author: Stefano Bortoli <s.bortoli@gmail.com>
Date:   2017-04-26T17:22:04Z

    Added code generation distinct aggregation logic


> SimpleStringUtils should be called StringValueUtils
> ---------------------------------------------------
>                 Key: FLINK-6338
>                 URL: https://issues.apache.org/jira/browse/FLINK-6338
>             Project: Flink
>          Issue Type: Improvement
>          Components: Core
>    Affects Versions: 1.2.0
>            Reporter: Stephan Ewen
>            Assignee: Stephan Ewen
>            Priority: Trivial
>             Fix For: 1.3.0

This message was sent by Atlassian JIRA

View raw message