flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-6286) hbase command not found error
Date Wed, 12 Apr 2017 14:33:41 GMT

    [ https://issues.apache.org/jira/browse/FLINK-6286?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15965966#comment-15965966
] 

ASF GitHub Bot commented on FLINK-6286:
---------------------------------------

Github user lingjinjiang commented on the issue:

    https://github.com/apache/flink/pull/3711
  
    Hi @greghogan , In the config.sh, there is a if statement identifies whether HBASE_CONF_DIR
is setted.
    If the HBASE_CONF_DIR is setted, then will use the "hbase classpath" command to add the
hbase's classpath to flink's classpath.
    But it does not  check whether  the "hbase" command is existed before using it. 
    Then in the host where I'm using flink, another application need this env variable and
there is no "hbase" command, then the error happen.


> hbase command not found error
> -----------------------------
>
>                 Key: FLINK-6286
>                 URL: https://issues.apache.org/jira/browse/FLINK-6286
>             Project: Flink
>          Issue Type: Bug
>            Reporter: Jinjiang Ling
>            Priority: Minor
>         Attachments: FLINK-6286-0.patch, FLINK-6286-1.patch
>
>
> As I'm using flink with the HBASE_CONF_DIR env variable and don't install hbase, then
I get the error message below.
> {quote}
> *bin/config.sh: line 303: hbase: command not found*
> {quote}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message