flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nico Kruber (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-4813) Having flink-test-utils as a dependency outside Flink fails the build
Date Tue, 14 Feb 2017 17:06:41 GMT

    [ https://issues.apache.org/jira/browse/FLINK-4813?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15866135#comment-15866135
] 

Nico Kruber commented on FLINK-4813:
------------------------------------

for documentation: until the minikdc dependency is made optional, users are required to add
the following to their build plugins:

{code:xml}
<!--
  https://issues.apache.org/jira/browse/DIRSHARED-134
  Required to pull the Mini-KDC transitive dependency
-->
<plugin>
	<groupId>org.apache.felix</groupId>
	<artifactId>maven-bundle-plugin</artifactId>
	<version>3.0.1</version>
	<inherited>true</inherited>
	<extensions>true</extensions>
</plugin>
{code}

> Having flink-test-utils as a dependency outside Flink fails the build
> ---------------------------------------------------------------------
>
>                 Key: FLINK-4813
>                 URL: https://issues.apache.org/jira/browse/FLINK-4813
>             Project: Flink
>          Issue Type: Bug
>          Components: Build System
>    Affects Versions: 1.2.0
>            Reporter: Robert Metzger
>
> The {{flink-test-utils}} depend on {{hadoop-minikdc}}, which has a dependency, which
is only resolvable, if the {{maven-bundle-plugin}} is loaded.
> This is the error message
> {code}
> [ERROR] Failed to execute goal on project quickstart-1.2-tests: Could not resolve dependencies
for project com.dataartisans:quickstart-1.2-tests:jar:1.0-SNAPSHOT: Failure to find org.apache.directory.jdbm:apacheds-jdbm1:bundle:2.0.0-M2
in https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will
not be reattempted until the update interval of central has elapsed or updates are forced
-> [Help 1]
> {code}
> {{flink-parent}} loads that plugin, so all "internal" dependencies to the test utils
can resolve the plugin.
> Right now, users have to use the maven bundle plugin to use our test utils externally.
> By making the hadoop minikdc dependency optional, we can probably resolve the issues.
Then, only users who want to use the security-related tools in the test utils need to manually
add the hadoop minikdc dependency + the plugin.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message