flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-4422) Convert all time interval measurements to System.nanoTime()
Date Wed, 22 Feb 2017 20:45:44 GMT

    [ https://issues.apache.org/jira/browse/FLINK-4422?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15879194#comment-15879194

ASF GitHub Bot commented on FLINK-4422:

Github user StephanEwen commented on the issue:

    Looks good, +1 to merge
    Optional comment: I have seen that developers get confused when working with the code
whether a `long` refers to a "millisecond" timestamp or to a "nanosecond" timestamp.
    One way to solve that is to put that into the variable names (like `MAX_DELAY_MILLIS`
or `deadlineNanos`). Another way is to use only milliseconds everywhere. Something like https://github.com/apache/flink/blob/master/flink-runtime/src/main/java/org/apache/flink/runtime/util/clock/Clock.java
can help to get the milliseconds in a more readable way than using nanoTime and multiplying.

> Convert all time interval measurements to System.nanoTime()
> -----------------------------------------------------------
>                 Key: FLINK-4422
>                 URL: https://issues.apache.org/jira/browse/FLINK-4422
>             Project: Flink
>          Issue Type: Sub-task
>          Components: Core
>            Reporter: Stephan Ewen
>            Assignee: Jin Mingjian
>            Priority: Minor
> In contrast to {{System.currentTimeMillis()}}, {{System.nanoTime()}} is monotonous. To
measure delays and time intervals, {{System.nanoTime()}} is hence reliable, while {{System.currentTimeMillis()}}
is not.

This message was sent by Atlassian JIRA

View raw message