flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wuchong <...@git.apache.org>
Subject [GitHub] flink pull request #3330: [FLINK-5795][TableAPI&SQL] Improve UDTF to support...
Date Sat, 18 Feb 2017 05:51:33 GMT
Github user wuchong commented on a diff in the pull request:

    --- Diff: flink-libraries/flink-table/src/main/scala/org/apache/flink/table/codegen/CodeGenerator.scala
    @@ -1463,21 +1465,23 @@ class CodeGenerator(
       def addReusableFunction(function: UserDefinedFunction): String = {
         val classQualifier = function.getClass.getCanonicalName
    -    val fieldTerm = s"function_${classQualifier.replace('.', '$')}"
    +    val functionSerializedData = serialize(function)
    +    val fieldTerm =
    +      s"""
    +         |function_${classQualifier.replace('.', '$')}_${DigestUtils.md5Hex(functionSerializedData)}
    --- End diff --
    I find that the md5Hex string in the fieldTerm is never used. What about using `CodeGenUtils.newName`
to generate a new function field name (as shown below). It is a common usage in `CodeGenerator`
and there must be no naming collisions and the generated name will be more readable. What
do you think @sunjincheng121 @fhueske ?
    CodeGenUtils.newName(s"function_${classQualifier.replace('.', '$')}")
    Regarding to another PR for scalar UDFs, I think you are right. We can that in this PR.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.

View raw message