flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aljoscha Krettek (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-4548) Refactor ContinuousFileMonitoringTest to use OneShotLatch
Date Wed, 25 Jan 2017 11:18:26 GMT

    [ https://issues.apache.org/jira/browse/FLINK-4548?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15837583#comment-15837583
] 

Aljoscha Krettek commented on FLINK-4548:
-----------------------------------------

I assigned it to you but I think you should also be able to assign it to yourself.

> Refactor ContinuousFileMonitoringTest to use OneShotLatch
> ---------------------------------------------------------
>
>                 Key: FLINK-4548
>                 URL: https://issues.apache.org/jira/browse/FLINK-4548
>             Project: Flink
>          Issue Type: Improvement
>            Reporter: Aljoscha Krettek
>            Assignee: Pattarawat Chormai
>            Priority: Minor
>              Labels: easyfix, newbie, starter
>
> Right now, the test has custom code that uses {{synchronized}}, {{notify()}} and {{wait()}}.
This could be simplified by using {{OneShotLatch}} which does that under the hood and makes
the intended behavior more obvious in the test.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message