flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From shaoxuan-wang <...@git.apache.org>
Subject [GitHub] flink pull request #3046: [FLINK-5386][Table API & SQL] refactoring Window C...
Date Mon, 09 Jan 2017 21:39:51 GMT
Github user shaoxuan-wang commented on a diff in the pull request:

    --- Diff: flink-libraries/flink-table/src/main/scala/org/apache/flink/table/api/windows.scala
    @@ -150,7 +147,7 @@ class TumblingWindow(size: Expression) extends GroupWindow {
       def as(alias: String): TumblingWindow = as(ExpressionParser.parseExpression(alias))
       override private[flink] def toLogicalWindow: LogicalWindow =
    -    ProcessingTimeTumblingGroupWindow(alias, size)
    +    ProcessingTimeTumblingGroupWindow(name, size)
    --- End diff --
    Better to keep using "alias" here. By the way,
    I found that the input of some functions use "name", like ProcessingTimeTumblingGroupWindow,
while some others use "alias", like TumblingEventTimeWindow. Better to change them consistently
to "alias". What do you think.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.

View raw message