flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-5026) Rename TimelyFlatMap to Process
Date Mon, 28 Nov 2016 11:27:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-5026?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15701733#comment-15701733

ASF GitHub Bot commented on FLINK-5026:

Github user kl0u commented on a diff in the pull request:

    --- Diff: flink-streaming-java/src/main/java/org/apache/flink/streaming/api/functions/co/CoProcessFunction.java
    @@ -50,7 +46,7 @@
      * @param <OUT> Output type.
    -public interface TimelyCoFlatMapFunction<IN1, IN2, OUT> extends Function, Serializable
    +public interface CoProcessFunction<IN1, IN2, OUT> extends Function, Serializable
     	 * This method is called for each element in the first of the connected streams.
    --- End diff --
    Also in the javadoc for the ctx, it should change to:
    A {@link Context} that allows querying the timestamp of... 

> Rename TimelyFlatMap to Process
> -------------------------------
>                 Key: FLINK-5026
>                 URL: https://issues.apache.org/jira/browse/FLINK-5026
>             Project: Flink
>          Issue Type: Improvement
>          Components: Streaming
>            Reporter: Aljoscha Krettek
>            Assignee: Aljoscha Krettek
>             Fix For: 1.2.0
> The method on {{KeyedDataStream}} would be called {{process()}} and the function itself
would be called {{ProcessFunction}}.
> The reason for this is that {{TimelyFlatMapFunction}} is a bit of a mouthful and with
the additions to the timer API and state the {{ProcessFunction}} could become the basic, low-level,
user-facing API for cases where users nowadays implement their own operator.

This message was sent by Atlassian JIRA

View raw message