flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig Foster (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-5013) Flink Kinesis connector doesn't work on old EMR versions
Date Mon, 14 Nov 2016 16:32:58 GMT

    [ https://issues.apache.org/jira/browse/FLINK-5013?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15664360#comment-15664360
] 

Craig Foster commented on FLINK-5013:
-------------------------------------

I can fix and verify on the EMR side but shouldn't the Maven enforcer plugin be used to prevent
Flink from building using versions that don't properly shade?

> Flink Kinesis connector doesn't work on old EMR versions
> --------------------------------------------------------
>
>                 Key: FLINK-5013
>                 URL: https://issues.apache.org/jira/browse/FLINK-5013
>             Project: Flink
>          Issue Type: Bug
>          Components: Kinesis Connector
>            Reporter: Robert Metzger
>            Assignee: Tzu-Li (Gordon) Tai
>            Priority: Critical
>
> A user reported on the mailing list that our Kinesis connector doesn't work with EMR
4.4.0: http://apache-flink-user-mailing-list-archive.2336050.n4.nabble.com/Kinesis-Connector-Dependency-Problems-td9790.html
> The problem seems to be that Flink is loading older libraries from the "YARN container
classpath", which on EMR contains the default Amazon libraries.
> We should try to shade kinesis and its amazon dependencies into a different namespace.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message