flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aljoscha Krettek (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-5000) Rename Methods in ManagedInitializationContext
Date Wed, 02 Nov 2016 17:32:58 GMT

    [ https://issues.apache.org/jira/browse/FLINK-5000?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15629745#comment-15629745
] 

Aljoscha Krettek commented on FLINK-5000:
-----------------------------------------

CC: [~srichter]

> Rename Methods in ManagedInitializationContext
> ----------------------------------------------
>
>                 Key: FLINK-5000
>                 URL: https://issues.apache.org/jira/browse/FLINK-5000
>             Project: Flink
>          Issue Type: Improvement
>          Components: Streaming
>    Affects Versions: 1.2.0
>            Reporter: Aljoscha Krettek
>            Priority: Blocker
>
> We should rename {{getManagedOperatorStateStore()}} to {{getOperatorStateStore()}} and
 {{getManagedKeyedStateStore()}} to {{getKeyedStateStore()}}. There are no unmanaged stores
and having that extra word there seems a bit confusing, plus it makes the names longer.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message