flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zentol <...@git.apache.org>
Subject [GitHub] flink pull request #2614: [FLINK-4773] Intoduce OperatorIOMetricGroup
Date Sun, 09 Oct 2016 06:37:25 GMT
GitHub user zentol opened a pull request:


    [FLINK-4773] Intoduce OperatorIOMetricGroup

    This PR introduces the OperatorIOMetricGroup, which encapsulates the insantiation of numRecordsIn/Out
counters. For clarity purposes the IOMetricGroup class was renamed to TaskIOMetricGroup.
    The underlying reasoning for this change is the reuse of specific operator counters for
the task (first operator numRecordsIn == task recordsIn). With this class we can more easily
do this within the metric system.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/zentol/flink 4773_metrics_opio

Alternatively you can review and apply these changes as the patch at:


To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #2614
commit 5f0f3598fa5d0fdf8b61d591e2bb94b74924ee0d
Author: zentol <chesnay@apache.org>
Date:   2016-10-07T11:02:10Z

    [FLINK-4773] [metrics] [refactor] Rename IOMetricGroup to TaskIOMetricGroup

commit df40a58c74e7f0fc3feec4a5848f1627bf4537dd
Author: zentol <chesnay@apache.org>
Date:   2016-10-05T13:04:03Z

    [FLINK-4773] [metrics] [refactor] Introduce OperatorIOMetricGroup


If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.

View raw message