flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-3999) Rename the `running` flag in the drivers to `canceled`
Date Tue, 18 Oct 2016 11:31:58 GMT

    [ https://issues.apache.org/jira/browse/FLINK-3999?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15585220#comment-15585220

ASF GitHub Bot commented on FLINK-3999:

Github user ggevay commented on the issue:

    Could you please explain why are the first and last commit (65b3ff78f100ed1b13ec2fcc727f4869823b5918
and ba4f429043f3985db5ab37a3902a6fee15a7440e) necessary? Are they related to FLINK-3999?

> Rename the `running` flag in the drivers to `canceled`
> ------------------------------------------------------
>                 Key: FLINK-3999
>                 URL: https://issues.apache.org/jira/browse/FLINK-3999
>             Project: Flink
>          Issue Type: Bug
>          Components: Local Runtime
>            Reporter: Gabor Gevay
>            Assignee: Neelesh Srinivas Salian
>            Priority: Trivial
> The name of the {{running}} flag in the drivers doesn't reflect its usage: when the operator
just stops normally, then it is not running anymore, but the {{running}}  flag will still
be true, since the {{running}} flag is only set when cancelling.
> It should be renamed, and the value inverted.

This message was sent by Atlassian JIRA

View raw message