flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-3909) Maven Failsafe plugin may report SUCCESS on failed tests
Date Thu, 19 May 2016 12:20:13 GMT

    [ https://issues.apache.org/jira/browse/FLINK-3909?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15291005#comment-15291005

ASF GitHub Bot commented on FLINK-3909:

Github user markreddy commented on the pull request:

    I took a look at the root issue of upgrading to 2.19.1. I'm able to reliably reproduce
this issue on my laptop. 
    When I bump the version I get the same as @tillrohrmann 
    When running the build in debug mode for both 2.18.1 and 2.19.1 I observed some differences
in the classpath. 
    `[DEBUG] boot(compact) classpath:  surefire-booter-2.18.1.jar  surefire-api-2.18.1.jar
 test-classes  classes  flink-core-1.1-SNAPSHOT.jar.....`
    `[DEBUG] boot(compact) classpath:  surefire-booter-2.19.1.jar  surefire-api-2.19.1.jar
 test-classes  flink-runtime_2.10-1.1-SNAPSHOT.jar  flink-core-1.1-SNAPSHOT.jar.....`
    So 2.19.1 has changed behaviour. What is loaded onto the classpath differs, in 2.19.1
instead of loading target/classes it loads the actual built jar. https://issues.apache.org/jira/browse/SUREFIRE-855
confirms this. 
    The issue with this is the final jar has curator shaded while the test classes are looking
for the unshaded version of curator, as shown by the debug output:
    If @mxm can get everything working on a lower version thats the easiest solution. If not
or we want to proceed with moving up in version, at least we know the root of the issue and
can work from there....

> Maven Failsafe plugin may report SUCCESS on failed tests
> --------------------------------------------------------
>                 Key: FLINK-3909
>                 URL: https://issues.apache.org/jira/browse/FLINK-3909
>             Project: Flink
>          Issue Type: Bug
>          Components: Build System
>    Affects Versions: 1.1.0
>            Reporter: Maximilian Michels
>            Assignee: Maximilian Michels
>             Fix For: 1.1.0
> The following build completed successfully on Travis but there are actually test failures:

This message was sent by Atlassian JIRA

View raw message