flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Metzger (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-3662) Bump Akka version to 2.4.x for Scala 2.11.x
Date Wed, 04 May 2016 09:06:12 GMT

    [ https://issues.apache.org/jira/browse/FLINK-3662?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15270358#comment-15270358
] 

Robert Metzger commented on FLINK-3662:
---------------------------------------

I think the whole project died for now because Akka 2.4 requires Java 8: http://akka.io/news/2015/09/30/akka-2.4.0-released.html


> Bump Akka version to 2.4.x for Scala 2.11.x
> -------------------------------------------
>
>                 Key: FLINK-3662
>                 URL: https://issues.apache.org/jira/browse/FLINK-3662
>             Project: Flink
>          Issue Type: Sub-task
>          Components: Build System
>    Affects Versions: 1.0.0
>            Reporter: Maximilian Michels
>            Assignee: Robert Metzger
>             Fix For: 1.1.0
>
>
> In order to make use of newer Akka features (FLINK-2821), we need to update Akka to version
2.4.x.
> To main backwards-compatibility, we have to adjust the {{change_scala_version}} script
to update the Akka version dependent on the Scala version.
> Scala 2.10.x => Akka 2.3.x
> Scala 2.11.x => Akka 2.4.x



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message